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Allegro Tips and Tricks   

This document provides Tips and Tricks recommended by Ed Hickey, Product Engineering Director of Cadence.  

 

Reducing Mouse Clicks & Travel (Various) 
Tips to help reduce the number of mouse clicks & travel to the options panel.  

Adding Vias – Use of Space Bar (All Levels) 
Adding a via has traditionally been done with a double left click of the mouse. The use of the space bar can save 

you 1000’s of mouse clicks per year. I suggest adding the function key below to your local env file. The spacebar 

entry is represented by “ “. Other keys can be assigned but space bar is easy to click without looking down. 

funckey " " "pop bbdrill -cursor" 

Adding Vias – “Working Layer” model (All Levels) 
The Working Layer “WL” model to add vias is available in all versions of PCB Editor. It can be used to add 

conventional through-hole or staggered/stacked HDI vias. Select your target routing layer from a popup GUI that 

appears adjacent to the via insertion area.    

o Order the vias in each Physical CSet 

o Click on the “…” to access alternative (least preferred) vias 

    

                   In Add Connect – Select ‘WL”   Select Target Layer during routing 

 

Add Connect – Single click execution (All Levels) 
In Etch Edit Application Mode, make a single pick on a pin, via or rat to begin Add Connect.  Ensure “Enable Single 

Pick Execution” mode is enabled. Access this option from the right click – Customize menu.  
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Add Connect – Add a vertex using a Funckey key (All Levels) 
Instead of using a left click to add a vertex point during Add Connect, consider using a Function Key. Simply click 

the X key every time you want to add a vertex during routing.  

funckey x "pick_to_grid -cursor" 

Slide – Single Click Execution (All Levels) 
In Etch Edit Application Mode, make a single pick on a cline segment to slide it.  

Change Active/Alternate Layers using Function Keys (All Levels) 
Increment or decrement the active or alternate layer 

funckey + subclass -+ (use of “+” character to increment active subclass) 

funckey - subclass -- (use of “-“ character to decrement active subclass) 

funckey a altsubclass -+ (use of “a” character to increment alternate subclass) 

Directly change the active layer 

funckey 1 options subclass TOP 

funckey 2 options subclass SIGNAL_2 

funckey 3 options subclass SIGNAL_3 

funckey 4 options subclass SIGNAL_4 

funckey 5 options subclass SIGNAL_5 

funckey 6 options subclass SIGNAL_6 

funckey 7 options subclass SIGNAL_7 

funckey 8 options subclass BOTTOM 

 Another method to change the active subclass is from a right click: 

Right click > Change Active Layer  

Deleting Elements using a Function Key (All Levels) 
I think I use this function key more than any other one. Just pass your cursor over a cline, segment, via, text or 

shape and click “d” to delete it. No click of the mouse! 

funckey d "prepopup; pop dyn_option_select @:@Delete" 

Moving Components – Single click execution (All Levels) 
In Placement Application Mode, make a single left click pick on a component to move it.  

Rotating a Component using a Function key (All Levels) 
Click the function key R to rotate a component during movement 

funckey r iangle 90 

Mirror a Component using a Funckey Key (All Levels) 
Click the function key M to mirror a component during movement 

funckey m "pop mirror" 
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Snapping using a Funckey Key (All Levels) 
While moving an object, use a function key to snap to various elements.  

  funckey f "prepopup;pop dyn_option_select 'Snap pick to@:@Figure'" 

funckey i "prepopup;pop dyn_option_select 'Snap pick to@:@Intersection'"  

funckey c "prepopup;pop dyn_option_select 'Snap pick to@:@Arc/Circle Center'" 

funckey v "prepopup;pop dyn_option_select 'Snap pick to@:@Via'"  

Alias commands to the Middle Mouse Wheel (All Levels) 
The “button” command can be used to alias the Middle Mouse Wheel to commands; works with SHIFT, CONTROL 

and SHIFT-CONTROL combinations.  

Examples:  

button Swheel_up subclass -+ 

button Swheel_down altsubclass -+ 

button Cwheel_up "roam y -$roamInc" 

button Cwheel_down "roam y $roamInc" 

button SCwheel_up "roam x -$roamInc" 

button SCwheel_down "roam x $roamInc" 

In Constraint Manager, those of us with ‘older eyes’ can use the CTRL + Middle Mouse Wheel to increase the font 

size.   

Find Components or Nets quickly (All Levels) 
Use CTRL+F for Components and CTRL+N for nets, then simply type the refdes or netname required. The 

component or net is highlighted and the item is zoomed to and centred. 
 

alias ~F "prepopup ; pop dyn_option_select 'Selection set@:@Clear all selections';set prompt;prompt 'Find Ref 

Des';refdes $prompt;zoom selection" 

 

alias ~N "prepopup ; pop dyn_option_select 'Selection set@:@Clear all selections';set prompt;prompt 'Find Net 

Name';net $prompt;zoom selection" 

Replacing Padstacks by window selection (All Levels) 
In General Edit Application Mode, window around the set of pins or vias you wish to change then use the right 

click > Replace Padstack > Selected Instances command.  

Optional selection window (All Levels) 
If a polygon selection window is desired; 

Right click > Selection Set > Select by Polygon, Lasso, On Path. 
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Z-Copy – a powerful utility (All Levels) 
This is a basic function that everyone should know.  

Create a Route Keepin area derived from the board outline 

Select Edit Z-Copy(Allegro) or Shape Z-Copy (OrCAD), adjust the options 

settings to class = ROUTE KEEPIN, Subclass = ALL. Enable ‘contract’ then 

enter value the route keepin will be offset from the board outline. Last 

step is to select the board outline.      

 

 

 

 

Did you know Z-Copy can be used to copy to multiple layers at 

once? 

For example, you wish to create multiple GND planes but the names of 

each subclass end in GND_5, GND_8, GND_13, etc. Use Z-Copy then in 

the options tab select one of the GND layers. Edit the numerical part of 

the layer then enter the wildcard ‘*’ as shown in the graphic below.  

 

 

Fix/Unfix Elements in the Design (All Levels) 
Tips to add and remove the Fixed Property 

 Quickly unfix all elements 

The quickest method to remove the fixed property from all elements in the Design is to: 

1.  Click the Unfix Icon      2. Then right click > Unfix All 

 

 

              

 

 

 

Fix a Symbol’s location 

Simply hover over the symbol then select the “Fix” command from the context sensitive right click menu. 
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Datatip display of the Fixed property 

You would like to know whether an element is fixed while hovering over it.  

 

Configure the datatip setting as shown below. You may want to enable other symbol related properties to also 

display in the datatip window. This is done from the Setup > Datatip Customization menu. Select symbol Instance 

under Object Type then enable the value for “FIXED”. 
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Datatip Options (All Levels)  

Controls for delay, location and disablement 

The User Preference Editor contains hundreds of variables. The “Search” box is a very handy mechanism.  In this 

example, I type in the word “datatip” then click Search. Variables to delay, locate and disable datatips are 

available to you. 

 



 
 
PCB Editor Tips and Tricks  

© 2020 Parallel Systems Limited  Page 7 of 25 

The complete set of variables related to Datatips is located in the Display > Datatips Category 

 
 

Status Form traffic lights (All Levels) 

Display > Status (Allegro) or Check > Design Status (OrCAD) Did you know you can click on the swatch to obtain a 

report?  

 

“Go to” X,Y Location (All Levels) 
Navigate to an X,Y location in the Design  

You wish to quickly go to a specific X, Y location in the Design; e.g.:  go to location x = 50, y = 50. 

Adjust your zoom level then make a click on the ‘P’ button located at the base of the canvas display. Enter in your 

coordinates then click ‘Pick’ 

Note – Ensure you set application mode = none for this behaviour 
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Disabling Custom Color Assignments (All Levels)  
You may inherit a board from another designer or shop and question some of the colour assignments. One quick 

method to disable colour overrides that may have been applied to nets, buses, Diff Pairs is to go into the colour 

form. Select the ‘Nets’ tab on top, you will see a button called ‘Hide Custom Colors’. Select that option to revert 

to ‘layer’ based colouring.  

 

 

Color Dialog – Open last folder used (All Levels) 

Set the variable color_lastgroup located in Setup - User Preferences - UI - Control_panel 

 

Display a Layer (All Levels) 

Click the color swatch box to the left of the subclass in the Options pane to quickly turn layers on/off during a 

command. You can also use the Enable Layer select mode in the Visibility tab to quickly turn layers on / off. 
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Invoking Allegro in No OpenGL mode (All Levels) 
It may be necessary to run Allegro in a No OpenGL mode; for example, hosting a Net Meeting. Consider creating a 

Desktop Shortcut for Allegro.exe with the –noopengl option.  

 

 

Display of Properties in the Canvas (All Levels)   
 Any property attached to an element can be displayed in the canvas. From the Display > Property (Allegro) or 

Check > Properties (OrCAD) menu, select the Graphics tab then select properties to display from the left column. 

Clicking the Create button writes out the property values and/or their name to the Class > Manufacturing, 

Subclass > Properties.   
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Suppress Pin-Pin Violations within the same symbol (All Levels)    
PCB Designers often use Constraint Regions to suppress pin to pin violations within the same symbol. The 

property ‘nodrc_same_sym_pin’ can be applied to the symbol but did you know it can also be applied to the 

drawing? Applying it at the drawing level has a global impact to all symbols. 

1. Open the filename.dra 

2. Edit > Properties > then select Drawing in the Find by Name field. 

 

 

3. Choose the required Properties on the left, they are added to the right. There are other Nodrc_Sym 
properties to include if required. 

 

 

4. Click Apply and the properties are added to the Drawing. 
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Locked property (All Levels) 
The Locked property was designed for Re-Use modules but did you know …. 

The property can be applied to a place replicate circuit to prevent accidental movement of its members. It can 

also be applied to a package symbol to prevent editing/deletion of the assembly outline or other data elements. 

Suggestion – consider applying the locked property to the symbol drawing file (at the library level). 

 

Creating a Command Shortcut with Scriptmode +e (All Levels) 
Adding a drawing level property in the previous tip was labour intensive. Let’s create a shortcut. 

1. Enter scriptmode +e in the command window. This echoes the commands you enter. 

  

2. Copy all the commands above to a single line 

3. Separate with semi-colons 

4. Map to a function key 

5. funckey e "property edit;setwindow form.find;FORM find name_type Drawing;FORM find 
find_by_name;FORM findname objlist 'Drawing Select';FORM findname done"  

6. Click the ”e” key then press ”ENTER” in the command window to launch the property editor dialog!! 

7. Ideally set this in your env file (located in %HOME%\pcbenv) so this is available in every design. 

 

Scriptmode +I (All Levels) 
 "scriptmode +i" is really a shorthand for "scriptmode +invisible" 

Let’s say you want to create an alias for toggling end cap display but don't want to see the parameter form appear 

while executing the script.  
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 alias ec "scriptmode +i; prmed; FORM prmedit display_enhance toggle; FORM prmedit done" 

DFA Dynamics – Controlling spacing bubble resistance (Allegro PCB Designer) 
Issue - When placing components to DFA rules, it’s difficult to pull back the component when the bubble appears. 

The resistance can be controlled by the “dfa_pause_level” variable located in Setup > User Preferences > 

Placement > DFA. Set to 0 for no resistance.  

 

Shape has “No Etch” Status – find it (All Levels) 
A dynamic shape is "out of date" BUT it is unfilled.   

You cannot find the shape in question.  It says it's at a particular XY location, on a particular layer, but there is 

nothing there. Turn on the ‘Bound’ colour item for that layer to locate the shape outline.  

 

 

Voiding of GND clines through GND Plane (All Levels) 
A method to auto-void GND sense lines being routed through a GND plane.    
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In the example below, a GND net is routed through a GND shape. The property 'void_same_net' was applied to 

the cline.  Edit > Properties (Allegro) or Edit > Object Properties (OrCAD) then select the shape and pick the 

property. 

How to convert non 

acute angles for shapes to round corners? (All Levels) 

Use Shape > Global Dynamic Parameters > Void Controls tab and set the Acute angle control to "Full Round". 

Static shapes get the same capability by setting the following variable in your env file (%HOME%\pcbenv)  

set eap_static_newsmooth env variable. 
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Adding Text from a file (All Levels) 
Tip to add text from a .txt file on disk 

• Run the add text command:   Add > Text 

• Set the desired text options on the Options Pane 

• Position the cursor with a left click at the location that you 
want the first line of text to start. 

• Right click and choose: Read from File 

 

Why does the system react slowly when moving a comp? (All levels) 
Most likely your large pin-count nets are scheduled Min Tree. Add a VOLTAGE property to large pin-count nets 

like VCC and GND by Setup > Constraints > Constraint Manager (Allegro) or Setup > Constraints (OrCAD), then on 

the Properties > Net > General Properties add the required Voltages to the Voltage column.   

Is my Database Optimized for Performance? (All Levels)  
The performance advisor provides suggestions to increase database performance. The command can be run from 

Tools > Database Check > Performance Advisor (Allegro) or Check > Database Check > Performance Advisor 

(OrCAD). 

 

Read Only Variables (All Levels)  
A method for a site administrator to make variables read only 
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Add a readonly entry under the respective variable. In the env file (%HOME%\pcbenv) In the example below, I 

wish to prevent the end user from modifying PSMPATH, PADPATH and STEPPATH. The command readonly 

XXXpath is added just below the "set psmpath" variable.   

 

To verify in PCB Editor, type readonly at the command line prompt. The window lists variables that are readonly  

 

When an attempt is made to change padpath in the User Preferences editor, the values are greyed out and un-

editable.: 

 

BBVIA GAP DRC reporting too many DRCs (All Levels) 
Under normal circumstances, Buried/Blind vias separated by less than the minimum bbvia gap rule will generate a 

DRC no matter how many layers separate them.  A drawing level property, BBVIA_SEPARATION, suppresses the 

DRC if the vias are separated by the specified layer span value or more. In the example below, the property value 

of “2” suppresses the DRC on the left side. To Set this use Edit > Properties (Allegro) or Edit > Object Properties 
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(OrCAD) then in the Find by Name dropdown in the Find Pane select Drawing and add the BBVIA_SEPARATION 

property to the Drawing.  

 

 

Working with Xnets (Allegro PCB Designer, OrCAD Professional) 
Tips for working with Xnets 

 

Create them – Assign default ESpice models to the discrete devices from the Analyze > Model Assignment menu. 

Resolve / Ignore any warnings then select the Auto Setup button to apply a default ESpice model to the discrete 

parts. 

Note – if the schematic design is Constraint Manager enabled (CM Flow) then xnets are created automatically and 

the steps above are not required. 
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Prevent them on an Instance basis - Assign the property no_xnet_connection at the component level either 

directly in the board or via a property in the schematic. 

Display them Xnets are now available in Constraint Manager. To view you can use Objects – Filter and turn on 

Nets of Xnet which will list both nets that are part of the xnet. 

  
 

 

Naming Convention – The Xnet name defaults to the Net name with the lowest alphanumeric character. In the 

above example, L is before S.  

 

Change the Xnet Name (Allegro PCB Designer only) – In Constraint Manager, select the Xnet then use RMB – 

Rename to choose either name of the xnet. 
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Diff Pair Gathering (All levels)  
Looking for tighter coupling at the gathering location?   

Decrease the value of the “padentry_factor” variable located in Route – Connect category of the User Preference 

Editor.  

 

 

                

                Default       Padentry set to 10 

Route a Tandem Diff Pair (All Levels) 

Pre route each member as shown in the graphic below then use add connect to route as a tandem pair. This 

assumes a Diff Pair constraint object has been created.  
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Display Length Meter for non constrained nets (Allegro PCB Designer, OrCAD 

Professional) 

Set the variable “allegro_etch_length” located in user preferences > Route > Connect 

 

 

Constraint Manager (Various) 
A few tips related to Constraint Manager  

Display propagation delay for unrouted nets in CM. (Allegro PCB Designer, OrCAD Professional) 

Enable the “unrouted” modes in Constraint Manager > Analyze > Analysis Modes > Electrical 

 

 

Sort results from worst case to best case margin (All Levels) 

Double Click Margin Column Header or right click > Sort 
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Display just the Failed Results (All Levels) 

Use Objects – Filter Header and enable Failed only checkbox or simply click on this Icon 

 

 

Display just nets that have constraints on them? (All Levels)  

Use Objects – Filter Header and enable Objects with Directly Set values or simply click on this Icon 

 

 

Segregate sections of CM with divider lines, i.e. identify the transition between buses and matched 

groups. (All Levels) 

In CM, View > View Options > unsupported and Enable ‘Object Type Dividers’ or simply click on this Icon 

     

Constraint Resolution (All Levels) 

You want to see how the constraint resolves between 2 objects? 

Use Display > Constraint (Allegro) or Check > Constraints (OrCAD) then window select the 2 elements to obtain 

spacing resolution; select single element for physical resolution. 

In the example below, I window selected the 2 clines of a Diff Pair to obtain spacing resolution. The actual 

measured gap is supplied in the middle section of the report.  
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Preventing Shorts (All Levels) 
 

✓ In PCB Editor, It is possible to override a DRC with properties, make sure that the nets involved don’t have 
the “NO_DRC” property on a pin(s).  

✓ Make sure there are no “waived DRCs” that are not valid. 

✓ Run DBDoctor to keep the design in sync and up to date. 

✓ Make sure the plane layers in the cross section form agree with the artwork control form (negative or 
positive). 

✓ Make sure the padstacks are designed properly; both Antipads and thermals 

✓ Include the IPC-D-356 netlist in your Fab Package; insist the Fabricator does a netlist to Gerber compare.    

 

Suppress SIGNOISE Warnings and Error messages (Allegro PCB Designer, OrCAD 

Professional)  
To suppress Signoise warning and error messages from appearing in the message window, set the variable in the 

env file. 

set sigsuppress ERROR WARNING 

Write vs Save (All Levels) 

You want to save the current board file you are working on as a new name but want to keep the current file open 

using its current name. The “Save As” function will make the saved file the active file. 

Enter “write” in the command window followed by a design name.  
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Autosave the Database (All Levels)  
Setup > User Preferences > File_management > Autosave. Variables to autosave the database 

 

 

Reopen command (All Levels) 

Most people do not know about this convenient command which does what is says, reopens a design file.  

Enter “reopen” in the command window to reopen the same file. 

 

File Management - artwork, plots, log files, reports (All Levels) 

Looking to manage your artwork, plots and reports more efficiently? There is a suite of variables beginning with 

ADS designed to create subdirectories for common data files. Setup > User Preferences > File_management > 

Output_dir. 
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Open File Manager from Allegro (All Levels) 
Quick method to explore to your working directory 

Tools > Utilities > File Manager (Allegro) or Tools > More > File Manager (OrCAD). 

Looking for a particular padstack based on hole size? (All Levels) 

There are 2 methods to obtain a report of library padstacks:    

1. Manufacturing > NC > Drill Customization > Library Drill Report (Allegro) or Manufacture > Customise Drill 
Table > Library Drill Report (OrCAD). 

2. Consider the Find by Query command available via the Find Pane. Set up a query to look for a particular 

Pin / via with a Finished hole size… 

 

Testability – Multiple Probe-Type Support (All Levels) 
The Testprep parameter form, Manufacture > Testprep > Parameters (Allegro) or Manufacture > Test points > 

Parameters (OrCAD) supports entries for multiple probe-types. The names (Probe Type) and centre to centre 

spacing (Probe Spacing) is user definable.  

To add a row in the form, select a Probe Type cell then right click > Add. 
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Drill Legend Support for INCHES and METRIC (All Levels) 

Update your default-units.dlt file as shown below (located normally %CDSROOT%\share\pcb\text\nclegend)  

?AlternateUnits "millimeters" 

?ColumnDefinitions '( 

                       ("Figure"      "FIGURE"        7) 

                       ("Holesize"    "SIZE"         15) 

        ("Tolerance"   "Tolerance"    15) 

        ("Holesize2"   "SIZE MM"      15) 

                       ("Tolerance2"   "TOLERANCE MM" 15) 

                       ("PlateStatus" "PLATED"       10) 

                       ("NonStandard" "NONSTANDARD"  15) 

                       ("Quantity"    "QTY"           6) 

                     ) 

Uprev Symbols (All Levels)  
The command “uprev_overwrite” can be used to uprev library files to the current software revision. 

Syntax – uprev_overwrite n where n = *.dra; *.psm; *.ssm, etc 

Ex – in a command window, enter uprev_overwrite *.dra to update all .dra files to the current software level.  

For more flexibility in upreving in a DOS command window do a: 

uprev -help 

** Be sure to make a backup copy of your library before uprev 

 

Troubleshooting – Running Allegro in Safe Mode (All Levels)  
Many Allegro programs support the "-safe" command line option. This starts the program without any user 

customizations or extensions. This can be used a debug mechanism to eliminate if user configurations are the 

cause of the problem with the product.  

It disables loading at start-up 
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• local env file (%HOME&/pcbenv/env) 

• cds_site configuration data 

• any user skill code 

• pre-register scripts 

• ini file which stores window size/position information  

• most recent used files (MRU) 

• remembered Windows positions (.geo files) 

In addition, graphic programs support the "-noopengl" option which will disable the enhanced Graphics based 

upon OpenGL. 

Example: Run an "out of the box" allegro without opengl 

            allegro -safe -noopengl 

Tips from Allegro PCB Users (All Levels)  
Join the Cadence Community Website and see what other users are saying 

https://community.cadence.com/cadence_technology_forums/f/pcb-design 
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