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Introduction 
 

To create an output package suitable for PCB Manufacturers you can create the files individually so that you have 

Gerber, NC drill and an IPC netlist or you can create one zipped file (called an ODB++) file which contains all the 

information required to manufacture a bare printed circuit board. You can also generate an IPC2581 which is a 

new file format that generates all the data in a single xml file that can be sent to fabricators, assemblers, test 

houses. This technical note describes how to generate all output files using PCB Editor required for bare board 

manufacture, either as separate files (RS274X Gerber, NC Drill and an IPC netlist), as one output file (ODB++ 

format) or using the IPC2581 export. 

NC Legend 
 

To generate the relevant NC Drill files using PCB Editor you need to do the following. If required you can create a 

drill table which will display the drill size, qty, type as specified in the Padstack defaults. To generate the drill 

table, use Manufacture > Create Drill table (OrCAD) or Manufacture > NC > Drill Legend (Allegro). The following 

GUI (default shown) gives the user the opportunity to define how the drill table will be displayed. 

 

Template File - Indicates the template to use to create the 

drill legend. Click the browse button to locate existing 

templates. 

Output Unit - Outputs the drill legend data in units that 

differ from those in the design. 

Library - Lets you view template files that are available via 

the NCDPATH variable that you set in User Preferences > 

Paths > Config. 

Legend Title - Indicates the drill legend title specified in the 

.dlt drill legend template file, which you can modify here. 

Drilled layers for each drill legend subclass are visually 

identifiable as a result. 

Drill - If the string $lay_nams$ or $lay_nums$ appears 

within the title string, the layer names or numbers are 

respectively substituted in the title for each generated 

legend table. For example, TOP to BOTTOM or 1 to 4, 

respectively. 

Backdrill - Indicates the backdrill legend title specified in the 

.dlt drill legend template file, which you can modify here, if 

you choose to generate a backdrill legend (optional). 

 

C-Bore - Indicates the counter bore/counter sink legend title specified in the .dlt drill legend template file, which 

you can modify here, if you choose to generate a drill legend (optional). 
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Hole Sorting Method 

By Hole Size - Defines how to sort hole sizes in the legend. 

Ascending -  Lists hole sizes from largest to smallest in the legend. 

Descending - Lists hole sizes from smallest to largest in the legend. 

By Plating Status - Indicates whether to list plated or non-plated holes first in the legend. 

Plated First -  Lists plated holes first in the legend. 

Non-plated First - Lists non-plated holes first in the legend. 

Legends - Each execution of this command generates one of the following types of legend, depending on which 

you have chosen. Layer Pair and By Layer legends are mutually exclusive. Generating one type removes the other 

if it exists in the design. 

Layer Pair - Choose to generate drill legends that represent holes to be drilled according to combinations of layer 

pairs. For example, for a four-layer board using thru via technology, this option represents the via that spans 

layers one through four as existing on the layer pair “1-4.” 

By Layer - Choose to generate multiple drill legends that represent each hole to be drilled for each via as existing 

between one entry layer and one exit layer, typically used to meet microvia technology requirements. For 

example, for a four-layer board, this option represents the via that spans layers one through four as existing on 

layer “1-2,” layer “2-3,” and layer “3-4” and displays it in three different drill legends. Note that no output appears 

for layer “1-4.” An <n> layer board therefore always has one fewer drill legend outputs than the total number of 

layers, or <n-1>, because a hole starting on one layer has to at least appear on the next layer as well, and a hole 

never appears on only one layer. 

Include Backdrill - Choose to generate backdrill size, must-not-cut-layer, maximum drill depth, and manufacturing 

stub length in addition to Layer Pair or By Layer drill legends, depending on your choice. 

Include C-Bore - Choose to generate drill legends for counter bore/counter sink structure, depending on your 

choice. 

 

Other Options 

Drill Legend Columns - Choose to display drill legend columns, depending on your choice. 

Tolerance drill - Includes tolerance for both circular drills and slots. 

Tolerance travel - Includes tolerance for a slot along the path. 

Tool size - Includes drill tool size or drill bit name. 

Rotation - Includes rotation for the square drills and slots. 

Non-standard type - Includes non-standard drill types such as laser, punch, and so on defined in the Padstack. 

Editor. 

Display total slot/drill count - Choose to display total number of slots or drills. 

Separate slots from drills - Choose to generate legends for drills separately. 

Suppress tolerance column if all values are 0’s - Choose to not display tolerance column if all values are 0. 

Suppress tool size column if all values are empty - Choose to not display tool size column if all values are nil. 

Suppress rotation column if all values are 0’s - Choose to not display rotation column if all values are 0. 

 

Once defined click OK and the NC Drill legend table will be attached to the mouse ready for the user to place in 

the design. The table contents can be modified prior to creation using Manufacture > NC > Drill Customization 

(Allegro) or Manufacture > Customize Drill table (OrCAD). This allows users to modify character types, sizes and 

drill tolerance. Once placed if your design uses blind or buried vias then all the tables are placed on top of each 

other. To move the tables so that they can be viewed separately use Edit > Move then using the Find Pane select 

Groups then left click the tables to move them to a clear space. Drop the table in the required location using a left 

click. A typical example of multiple tables is shown below. The drill chart title includes the start and end layers for 
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the drill (the first table shows drills from TOP to BOTTOM or through holes, the next drill chart shows INNER1 to 

INNER2 or buried drill holes). 

 

 
 

` 

NC Drill 
 

Once The PCB is ready for manufacture you will need to create NC Drill files. These list the drill types, and x, y 

locations suitable for fabricators to use directly. Most Gerber viewers will read a NC Drill file and show the drill 

holes in the correct locations. To generate an NC Drill file use Manufacture > NC > NC Drill (Allegro) or Export – NC 

Drill (OrCAD). The following GUI is displayed and described below. 

Root File Name - Enter a base filename for output text files 

before any appended extension. If you do not specify a 

filename extension, .drl is the default, which you can change 

by setting the ext_drill environment variable in Setup > User 

Preferences > File_management > Versioning. The filename 

defaults to <design name>-<l1>-<l2>.drl, where <l1> and 

<l2> are the two drilled layers. When you choose to 

generate separate files for plated and non-plated holes, non-

plated filenames are <design name>-np-<l1>-<l2>.drl. Holes 

defined on the Padstack Designer with Non-standard Drill 

types of Laser, Plasma, Punch, and Other output to separate 

files named <design name>-laser, <design name>-plasma, 

<design name>-punch, <design name>-other. For example, 

for non-plated holes that use non-standard drilling, the filename is <design name>-laser-np-1-2.drl. The naming 

conventions for backdrill files are drill-bd-top-<l2>.drl and drill-bd-bottom-<l2>.drl; for By Layer files, drill-bl-<l1>-

<l2>. 

Scale Factor - Indicates the value by which all drill locations in the output drill files are multiplied, to scale the X 

and Y drill locations. 

Tool Sequence - Specifies whether the tool sequence starts with the smallest drill size and increases, or with the 

largest drill size and decreases. The default is increasing. 
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Auto Tool Select - Inserts Tnn tool-select codes into the data portion of the Excellon-format output file, instead of 

M00 stop codes for manual tool changing. Tnn codes automatically generate in sequence (for example, T01, T02, 

… Tnn). Tnn tool-diameter specification codes only append to the tool-select code in the header portion of the 

Excellon-format output file, expanding to a TnnC.xxx format to specify the required router bit size, if you enabled 

Enhanced Excellon Format in the NC Parameters dialog box. For example, T01C.045 specifies that Tool 1 has a 45-

mil diameter. You can also opt to associate specific tool sizes with specific Tnn tool codes in an nc_tools.txt file, 

which is used if it exists; otherwise, NC Drill automatically determines the appropriate tools the design needs and 

assigns tool codes to them. An nc_tools_auto.txt file is created for reference. A warning message appears when 

an nc_tools.txt file is not found. (It is recommended that this is checked for NC Drill creation). 

Separate Files for Plated/Non-plated holes - Choose to generate separate files for plated and non-plated holes. 

Repeat Codes - Specifies whether your drill supports repeat codes. Enabled by default. 

Optimize Drill Head Travel - Choose to optimize drill travel on the NC Drill output files.  

Drilling - Each execution of this command generates one of the following drill output files, depending on which 

you have chosen. Layer Pair and By Layer drill-output files are mutually exclusive. Generating one type removes 

the other if it exists in the design. 

Layer Pair - Choose to generate drill output files that represent the holes to drill according to combinations of 

layer pairs. For example, for a four-layer board using thru via technology, this option represents the via that spans 

layers one through four as existing on the layer pair “1-4.” 

By Layer - Choose to generate multiple drill output files that represent each hole to drill for each via as existing 

between one entry layer and one exit layer, typically used to meet microvia technology requirements. For 

example, for a four-layer board, this option represents the via that spans layers one through four as existing on 

layer “1-2,” layer “2-3,” and layer “3-4” and displays it in three different drill output files. Note that no output 

appears for layer “1-4.” An <n> layer board therefore always has one fewer drill output files than the total 

number of layers, or <n-1>, because a hole starting on one layer has to at least appear on the next layer as well, 

and a hole never appears on only one layer. 

Include Backdrill - Choose to generate drill output files for back drilling in addition to Layer Pair or By Layer drill 

legends, depending on your choice. (Allegro PCB Designer). 

Include counterdrill – Choose to include the counterbore / countersink hole in the NC Drill file. These are added 

as part of the secondary drill option in Padstack Editor. 

Drill - Click to generate NC Drill output files. 

 

Parameters - Click to access the NC Parameters Dialog Box 

dialog box. This is required prior to creating the drill files. 

To setup the NC parameters left click on Parameters or 

access from Manufacture > NC > NC Parameters (Allegro) 

or Export > NC Parameters (OrCAD). The parameters GUI 

will display as shown (left) with the following options. 

 

Parameter File - Enter the name and path of the file to 

which to save the NC parameters when you exit this dialog 

box. The default path is your current working directory. 

Click ... to open a file browser from which you can choose 

an existing file. 

Output File 

Header - Specifies one or more ASCII headers in the output 

file with a maximum of 1024 characters.  
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Leader - Specifies the leader length. The default is 12. 

Code - Specifies the output format. The default format is ASCII. 

Excellon Format 

Format - Identifies the coordinate data in the output NC Drill file. The integer that you enter to the left of the 

decimal point sets the number of digits displayed before the decimal point. The integer that you enter to the right 

of the decimal point sets the number of digits displayed after the decimal point. The default value is 2.3. 

Offset X, Y - Identifies the offset from the drawing origin for the coordinate data in the output files specified in 

the File Name fields in this dialog box. The default 0,0. 

Coordinates - Specifies whether the output coordinates as incremental or absolute. The default setting is 

Absolute. 

Output Units - Specifies output units as English or Metric. The default is English. 

Trailing Zero Suppression - Choose to eliminate trailing zeros in the output coordinate data. Default is unchecked. 

Leading Zero Suppression - Choose to eliminate leading zeros in the output coordinate data. Default is 

unchecked. 

Equal Coordinate Suppression - Specifies whether equal coordinate data is suppressed. The default is unchecked. 

Enhanced Excellon Format - Choose to generate a header in NC Drill and NC Route output files that more fully 

uses Excellon commands. The header starts with M48 and ends with % and lists tool specifications, the 

appropriate INCH/METRIC command appears, and LZ/TZ as required for padding the leading or trailing zeros in 

the data section. The Tnn tool-diameter specification codes expand to a TnnC.xxx format to specify the required 

router bit size. (It is recommended that this is checked for NC Drill creation). 

 

NC Route (if required) 
If your design uses slots (defined in Padstack Editor) or has an Ncroute_path defined for cutouts and the board 

outline then this information is not included in the NC Drill file. You will need to generate an NC Route file to 

include this information. To generate an NC Route file use Manufacture > NC > NC Route (Allegro) or Export – NC 

Route (OrCAD). The following GUI is displayed and described below. 

Root File Name - Specifies the name of the design for 

which you are running the output. 

Route Feedrate - Specifies in inches per second the 

routing tool’s speed. 

Separate files for plated/non-plated routing - Choose 

to generate two output files for plated/non-plated 

routing with “_plated” appended to the route file name 

for the plated output. 

Route - Click to generate the output files. 

Parameters - Click to access the NC Parameters Dialog Box. (Same NC Parameters and NC Drill). 
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Artwork Creation. 
 

There are several different formats for Gerber creation. Many older Gerber formats require a separate aperture 

list to be created and supplied with the artwork file. The most common artwork format used is RS274X which has 

the aperture data embedded into it so there is no need for a separate aperture file. This format will be used in 

this technical note.  

To start you will need to define the artwork films. This is done using a combination of Display > Color Visibility and 

Manufacture > Artwork. This basic principle is to set the display or colour settings as you would expect for an 

artwork using Display > Color Visibility (Allegro) or Setup > Colors (OrCAD), then create a film for that display e.g. 

for a TOP ETCH artwork you would need to display class/subclass for ETCH/TOP, PIN/TOP and VIA/TOP. Create the 

films you require by using Manufacture > Artwork (Allegro) or Export > Gerber (OrCAD) then on the Film Control 

tab right click on any film name and choose Add to add the displayed colors to a film name of your choice. By 

default, any layers in the cross section are created automatically as you add layers to your design or you can press 

the Create Missing Films button (only active when layers have been added to the cross section) but not the 

artwork film tab. You can load pre-defined artwork films using a Parameter file or by pressing the Add button 

which allows you to load a FILM_SETUP.txt file. See the Parameters technical note for reference. The GUI’s shown 

below are the Manufacture > Artwork (Allegro) or Export > Gerber (OrCAD) Film Control and General Parameters 

tabs. The options are described below. 

           

Film Control Tab 

Available Films - Choose a record by clicking the check box. Expand or collapse the layers in a record by clicking 

the plus or minus sign (+ or -) to the left of the record. If the database does not contain any film control records, 

the tool creates a default film record for each ETCH class. This record consists of etch, pins, and vias. 

Select All - Lets you choose all the available films. 

Add - Click to launch the Select Film File to Add dialog box from which you can choose a previously created film 

record(s). 

Replace - Click to substitute another film record for the currently selected record.  
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Check Database Before Artwork - Click the check box to verify the integrity of a drawing database prior to 

generating artwork by invoking the DBdoctor database-checking program. If DBdoctor detects errors in the 

database, the tool does not generate artwork. 

Create Artwork - Generates artwork for each film record you checked. A message appears on the dialog box 

informing you of successful completion of the process. If an error occurs, the message informs you to look at the 

output file. 

Film Options – These are based on each film. They need to be defined for ALL films separately. 

Film name - Displays the name of the film record to be edited. You cannot edit this field. You must change the 

name in the Available Films section on the Film Control tab of the Artwork Control Form dialog box by first 

highlighting the film name and then clicking it. You can also perform the renaming task within a script. 

PDF Sequence - Specifies the sequence number of films in the PDF output. You can override the order of films in 

PDF output. If two films are assigned a same sequence number, they are sorted in the alphabetical order. 

Rotation - Specifies the rotation of the plotted film image. A drop-down list displays the angle of rotation. Choices 

are 0, 90, 180, and 270. The default is 0. 

Offset X Y - Specifies the x and y offset to add to each photoplot coordinate. If you enter positive x and y offsets, 

all photoplotted lines shift in the positive direction on the film. The default is 0. 

Undefined Line Width - Determines the width of any line that is undefined. This can be set as a user preference 

(Setup > User Preferences > Manufacture > Artwork. Set the artwork_undef_line_width to the required value. Any 

artworks generated after this has been set will take on this value. 

Shape Bounding Box - Applies to negative film. Vector artwork uses this value to extend the shape fill for a 

negative layer beyond the board outline by that value. Raster artwork for negative layers adds fill from the edge 

of the shapes to the photoplot outline. If the shape bounding box value is positive, the fill extends that distance 

beyond the photoplot outline. When no photoplot outline exists, raster format draws fill up to the board 

geometry outline as it does with vector formats. If the shape bounding box value is positive, the fill extends that 

distance beyond the board geometry outline. 

Plot Mode - Specifies whether the photoplot output is positive or negative. The default is positive. 

Film Mirrored - Specifies whether the photoplot output is to be mirrored. The default is not mirrored. 

Full Contact Thermal Reliefs - Applies to negative film. When you choose this option, a pin or via that is 

connected to a shape uses no flash, which causes a solid mass of copper to cover the pad. If you do not choose 

this option, a pin or via connected to a shape uses a thermal-relief flash. The default is no selection. 

Suppress Unconnected Pads - Specifies that the pads of pins and vias that have no connection to a connect line or 

shape in a Gerber data file are not plotted. This option applies only to internal layers and to pins whose padstack 

has the suppression of unconnected internal pads enabled. Selecting this option also suppresses donut antipads 

in raster-based negative artwork. When disabled, for negative plane layers, donut pads generate based on the 

regular and antipad definitions in the padstacks. In this case, padstacks must be set up so that the regular pad is 

smaller than the antipad so an annular ring, suitable for manufacturing, is formed. Caution: If the value of regular 

pads is not less than the antipad value in the padstack, the donut pad will be missing in the artwork file. Enabling 

the Dynamic unused pads suppression option, available by running Setup – Unused Pads Suppression (unused 

pads command) enables this option for all films; suppression occurs as required for just those films needing it, 

despite all films displaying as checked. Otherwise this option is greyed out. With the Dynamic unused pads 

suppression option disabled, this option’s functionality remains unchanged. Unconnected outer pads of the vias 

on internal layers are never suppressed. 

Draw Missing Pad Apertures - Choose this option to allow vector artwork to use line apertures to outline and fill 

pads with no matching aperture in the art_aper.txt file. Not selecting this option means that such pads are not 

drawn. (A warning is written to the photoplot.log file if this is the case). The default is no selection. 

Use Aperture Rotation - Specifies whether to use the aperture rotation. The default is no selection. 
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Suppress Shape Fill - Available for Gerber 6x00 and Gerber 4x00 only. Specifies that the area outside the shapes 

and all voids is not to be filled on a negative film. You must replace the filled areas with separation lines before 

running the artwork command. This option is useful for negative nested shapes. 

Vector based pad behavior – Specifies that raster artwork uses vector based (Gerber) behaviour to determine 

which type of pad to flash. 

Draw holes only – Choose this option to draw holes in artwork. This option is only enabled when pins and/or vias 

and no conductor layers are set up in the film record. For positive photoplot this option generates raster artwork 

output as shapes that are equal to the size of holes. For negative photoplot this option generates raster artwork 

output as shapes with voids which are equal to the size of the holes. 

Ouput pVia cut masks -  

 

Film Record Pop-up menu - The Film Record pop-up menu appears when you right-click a film record. It includes 

the following options: 

Display for Visibility -  Displays the visibility updates in the Color form for class/subclass. This menu disables all 

subclasses, and then enables the subclasses that you select in the film record. 

Display for Artwork Check - This menu performs the same function as Display for Visibility. In addition, it changes 

the settings in the Design Parameter Editor dialog box for the Enhanced display modes in Display tab: Disables 

modes for the thermal pads and holes, if they were enabled. Enables the Filled pads and Connect line endcaps, if 

they were disabled. 

Add - Opens a dialog box and adds a new film record after the selected film. The list of classes and subclasses 

contains those that appear in the current design window. 

Cut - Deletes the selected film layer. Your design must always contain at least one film layer. 

Undo Cut - Undoes the cut action that you just performed. 

Copy - Adds a copy of the selected layer directly beneath the layer. The copy is named “Copy_of_ ”. 

Save - Saves changes made to a layer during the current session. When you reload the board, the film record is re-

created. 

Save All Checked - Saves multiple films to an external file. 

Match Display - Deletes all class and subclass items from the film and replaces them with the list of classes and 

subclasses that appear in the current window. 

Select All - Lets you choose all the available films. 

Deselect All - Deselects the films you have chosen. 

Layer Pop-up Menu - The Layer pop-up menu appears when you right-click a class/subclass in a film record. This 

pop-up box has the following options: 

Add - Displays the Subclass Selection window. You can choose one or more subclasses to add to the selected film 

record. 

Cut - Deletes the class or subclass. 

 

General Parameters Tab - The General Parameters tab shows different parameters and defaults for each 

photoplotter model type, depending on which type you choose. The selection that you make in the Device Type 

section in the upper left-hand corner determines the available controls for that plotter and displays only those 

options in the dialog box. 

Device Type - Lets you specify the photoplotter model (Gerber 6x00, Gerber 4x00, Gerber RS274X, Barco DPF, or 

McDonald Dettwiler (MDA)) for which the tool writes artwork data files. Choose one photoplotter at a time. To 

display parameters that apply to a different photoplotter mode, click on another model. 

Film Size Limits - Enables you to specify the dimensions of the film used by the photoplotter. This parameter 

prevents the creation of plot commands with dimensions that are larger than the actual film in the plotter when 
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you run the artwork command. If the editor finds any elements that plot outside the boundaries given by Max X 

and Max Y, it writes the data to the artwork file anyway, and also writes a warning to the log file. 

Coordinate Type - Applies only to Gerber 6x00 and Gerber 4x00 device types. Enables you to specify whether the 

photoplot coordinates are the absolute distance from the drawing origin (Absolute) or the relative distance from 

the last coordinate (Incremental). 

Error Action - Specifies the action when an error is found —such as an undefined aperture—while processing the 

artwork files. The choices are: 

 Abort Film: Discards the data about the film file in error, but continues processing any other films still on 

the list. 

 Abort All: Aborts the entire process; no additional artwork files are created. 

In either selection, errors are written to the log file and its action recorded. 

Format - Lets you specify the number of integer places and the number of decimal places in the output 

coordinate fields. The two format fields are: 

 Integer Places: Specify a number between 0 and 5. 

 Decimal Places: Specify a number between 0 and 5. 

The format refers to either English (inch) or metric (millimetre) and should be set based on the output unit. For 

example: 

 Database Unit Accuracy = Format 

 MILS  0  = 2.3 

 MILS  1  = 2.4 

 MILS  2  = 2.5 

 MILS  3  = 2.6 not available 

 MILS  4  = 2.7 not available 

 INCH  2  = 2.2 

 INCH  3  = 2.2 

Roundoff occurs to artwork output data generated from boards created at accuracies higher than the number 0.5 

decimal equivalent. Cadence recommends designing data at or below the accuracy level the fab vendor supports. 

Output Options - These miscellaneous options do not apply to Gerber RS-274X, Barco DPF, or MDA device types. 

Optimize Options - Applies only to Gerber 6x00 and Gerber 4x00 device types. Sorts coordinates to minimize 

photohead travel time. Laser plotters optimize the data at plot time, making this step unnecessary for artwork. 

This is the default setting. 

Use ‘G’ codes - Applies only to the Gerber 4x00 device type. Specifies G codes in the Gerber data. Gerber data 

uses G codes to describe an upcoming process, for example, prepare to receive x, y coordinates, prepare to 

choose aperture, or prepare to flash aperture. Gerber 4x00 photoplotters support G codes. 

Suppress - Does not apply to the Barco DPF device type. Controls whether the tool writes leading or trailing 

zeroes or equal coordinates in the Gerber data file. 

Leading Zeroes - Suppresses the writing of leading zeroes for coordinates in the Gerber data file. This is the 

default setting. 

Trailing Zeroes - Suppresses writing trailing zeroes for coordinates in the Gerber data file.  

Note:  You can suppress either leading or trailing zeroes, or you can suppress neither leading or trailing zeroes, 

but you cannot suppress both leading and trailing zeroes. 

Equal Coordinates - Suppresses the writing of duplicate coordinates in the Gerber data file. This is the default 

setting. Gerber photoplotters are modal, which means that they retain old values until they read a new one of the 

same type. This means that coordinates with the same value do not need to be written more than once. This 

option reduces the size of the Gerber data file. This is the default setting. 
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Output Units - Applies only to Gerber RS274X device types. Lets you specify the output units as inches, 

millimetres, or mils. 

Max Apertures per Wheel – Applies only to Gerber 6x00 and Gerber 4x00 device types. Lets you specify the 

maximum number of apertures that the photoplotter wheel uses. Enter a value between 1 and 99. Photoplotter 

wheels have a maximum number of apertures. If your layout uses more than the number specified in this setting 

the tool writes a warning to the log file.  

Global Film Filename Affixes 

Prefix - Adds a user-defined, case-sensitive string before generated film filenames on a board-level basis, allowing 

a maximum 512-character filename, such as a part or revision number, which may be useful for larger boards with 

many layers and numerous artwork films as a result.  

Suffix - Appends a user-defined, case-sensitive string after generated film filenames on a board-level basis, 

allowing a maximum 512-character filename, such as a part or revision number, which may be useful for larger 

boards with many layers and numerous artwork films as a result. 

For both prefix and suffix names must be legal filenames and cannot contain directory names. Although 

Allegro permits filename affixes of 512 characters, many operating systems limit filenames to 256 characters 

(including extensions). Consequently, Cadence recommends film filenames (affixes plus filename plus extensions) 

be less than 256 characters.  

Note: You can also change the default file extension of .art for artwork film filenames by setting the ext_artwork 

environment variable in the User Preferences Editor, available by choosing Setup > User Preferences > 

File_management > Versioning. 

Continue with Undefined Apertures – Available for Gerber RS274X, Barco DPF and MDA device types. Check to 

continue to generate the Gerber data file when a definition for a flash aperture in the padstack is missing. 

Messages about the undefined apertures are written to the log file. If you do not check this box, the process stops 

when an aperture definition is not found. 

Scale Factor for Output - 

Value causes all entries in the artwork file to be scaled vertically and horizontally. If you use the default of 1.0000,

 no scaling occurs. If you enter a different value, the artwork output is scaled and a recommended aperture 

table is added to the photoplot.log file. For example, a value of 0.5 reduces each artwork entry by 50 percent; a 

value of 2.0000 increases each entry by 100 percent. The field accepts a total of eight characters, including the 

decimal point. The maximum number of decimal places is four. Add the recommendation in the photoplot.log file 

to the aperture table that accompanies the artwork file to manufacturing. This assures that the scaled apertures 

have the correct width and size. 

OK - Saves the settings and closes the dialog box. 

Cancel - Closes the dialog box. 

Apertures - Click to display the Edit Aperture Wheels dialog box. 

Viewlog - Displays the photoplot_out.log that contains messages generated after you create artwork, and is 

available only after you have done so. This log limits the 0 width line warnings to a maximum of 2 unless you set 

the artwork_all warnings environment variable in your local .env file. 

 

Once the artworks are created they are stored in the job directory (same location as the PCB board file). 

Alternatively you can define a specific directory for them by defining the ads_sdart variable from Setup > User 

Preferences > File_management > Output_dir. 
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IPC Netlist. 
It is recommended that when you send Gerber and drill files to the PCB manufacturer that you also send an IPC 

356 netlist. Normally if you do not the manufacturer will create a netlist from the Gerber files received. The 

biggest issue with this is that if your Gerber data is incorrect, the netlist that the completed bare board will be 

tested to would also have those errors. By sending an independent IPC 356 netlist means that should there be any 

issues with the Gerber data, these will be flagged earlier in the manufacturing process because the manufacturer 

can check the Gerber data to the netlist. To create the netlist use File > Export > IPC 356..(Allegro) or Export > IPC 

356..(OrCAD). The following GUI will appear, the settings are described below. 

Output File - The name of the output file you want to create. You can 

use the Browse button to find a previously created file. 

IPC Version – Choices are  

IPC-D-356 Supports the base substrate electrical test data format. 

IPC-D-356A Supports the standard format as well as buried and blind 

via extended records. 

Board title - A title for the board data you are extracting. If you do not 

enter a title here, the current board filename is used. 

Identification number - A number to identify this data. This number 

indicates the part number for data you want to define in a job set or in a parameter record, such as the artwork 

number, or schematic number. The program assigns 001 as the identification number if you do not enter a 

number. 

Revision - A revision number to help track your data. The program assigns A as the revision level if you do not 

enter a revision identifier. 

Header file - The header file you want to use. Click the button to the right to browse for the correct header file. 

The header file is a text file that contains any comments, specifications, or descriptive data you want to include in 

the output file. You create this with a text editor in your current working directory. The editor inserts the 

information from the header file as comments into the beginning of the output file. 

 

The completed netlist file is stored in the job directory as filename.ipc. This can be viewed in a text editor. 

ODB++ Data. 
Many PCB manufacturers will accept ODB++ data. This single compressed zip file contains all relevant 

manufacturing data combined. Users still need to define the artwork films and correct drill sizes but the outputs 

of the PCB is controlled in a single executable. To run this use File > Export > ODB++ Inside...(Allegro) or Export 

ODB++ Inside (OrCAD). The first time this is run the user will get the following screen  

 By clicking on Yes will take the user to the 

internet so that they can download and install 

the ODB++ Inside software. Once installed this 

will allow the user to create and view ODB++ 

files. 
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Next time you run the Export > ODB++ Inside... First you see the following question:- 

 

During export from PCB Editor (Allegro and OrCAD), the attribute NET_IMPEDANCE_AVERAGE is calculated for 

each net even though the attribute is not used in any Trilogy / Enterprise analysis. This slows down extraction 

considerably. The valor_ext.il import script prompts for permission to skip this calculation. As a result, extraction 

time is reduced. Therefore, it is recommended that you click on No for default extractions. The following GUI will 

then be displayed. 

 

To enable more than the default options click on Show more options – Yes then follow through the wizard. 

For a full list of options and settings please refer to brd2odb.pdf found in the default MentorGraphics directory 

C:\MentorGraphics\ODB++_Inside_Cadence_Allegro. 

IPC2581 
PCBs have changed significantly over the past three decades, yet to the surprise of many, we still commonly use 

30-year-old ways of communicating design intent to manufacturing. These decades’ old data-communication 

formats were originally conceived to drive the emerging numerically controlled machines. Gerber format, 

properly implemented, is perfectly adequate to transfer image data, but it does not transfer stackup data, 

materials, design intent or netlist.  IPC, the trade group, has been aware of the challenges and dynamics of the 

PCB design and manufacturing segment and has been an ardent advocate for the replacement of these old data-

communication formats. 

 

In early 2001, iNEMI (the International National Electronics Manufacturing Initiative) stepped in to lead a broad, 
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industry-wide project to define the definitive data exchange convergence specification. The goal was to enable 

accurate, efficient data exchange between designers and manufacturers of printed circuit boards (PCB) and 

assemblies using a single XLM-based data exchange format. From this effort, an IPC committee developed a new 

standard, IPC-2581, Generic Requirements for Printed Board Assembly Products Manufacturing Description Data 

and Transfer Methodology; it was released in March 2004. 

 

With IPC-2581, the industry finally has a global opportunity save millions of dollars by implementing a 

standardized safe and complete transfer of designs data and save millions of dollars wasted by managing multiple 

files in different formats. But as usual with data format specifications, nothing can be done until the supply chain 

produces, consumes and supports such a specification. This is where a new consortium of PCB design software 

(EDA) and supply chain companies fits in: to bring companies together to enable, facilitate and drive use of IPC-

2581.  

To create an IPC2581 file select File > Export > IPC2581 (Allegro) or Export > IPC2581 (OrCAD):- 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

IPC2581 Export Tab 

Output file name -  Enter the name of the IPC2581 file. 

Browse -  Lets you choose an output file from the list of .cvg files. 

IPC2581 version -  Specifies the version number IPC2581 data format. 

Output units -  Specifies the output unit to export. 

Functional Mode -  Specifies the global mode of the file. There are five valid values: 

FULL Everything is included 

DESIGN File contains design start or complete description 

FABRICATION File contains fabrication information 

ASSEMBLY File contains assembly information 

TEST File contains testing information for bare board or assembly 

Level - Specifies the data complexity of the IPC2581 file needed for each functional mode. There are three valid 

values 1, 2, and, 3. 
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Layer Mapping Edit -  Specifies Class/Subclass for outer copper layers, inner layers, documentation layers, solder 

mask and solder paste legend layers, and miscellaneous image layers. 

Film Creation -  Add/update film records for layer mapping. 

Vector text -  Select to export the text characters as line segments. 

Compress output file -  Select to generate the compressed IPC2581 file. 

Export Property Tab - Available properties Click to add properties to export for component and net. 

Once set Click on Export to generate an IPC2581 xml file. 
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