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Migrating a Microsoft Access CIS Database to Microsoft SQL Server 
Some users may find that there are restrictions when using a Microsoft Access database with OrCAD Capture CIS 

that can be avoided by moving away from a file-based database to a server-based database, like Microsoft SQL 

Server. Microsoft provide the Microsoft SQL Server Migration Assistant for Access, a free download, to migrate 

the database and provide Microsoft SQL Server Express, a restricted capability version of Microsoft SQL Server 

and a free download, for users who don’t need the capacity of a purchased Microsoft SQL Server installation. The 

restricted capabilities of Microsoft SQL Server Express are very unlikely to pose any capacity, or performance, 

issues with OrCAD Capture CIS users. 

The Microsoft SQL Server Migration Assistant for Access provides a wizard for migrating the Access database, but 

this cannot be used to migrate Microsoft Access databases used with OrCAD Capture CIS as the default data types 

for the migration are not compatible with the requirements of a database used by OrCAD Capture CIS. 

If the Migration Assistant Wizard has been used previously 

If the wizard has been used previously to migrate the Microsoft Access database, the target database in the 

Microsoft SQL Server will need to be removed since the Microsoft SQL Server Migration Assistant for Access won’t 

change the structure of an existing Database. Start the Microsoft SQL Server Management Studio and locate the 

target database, open the Databases collection and right-click>Delete on the target database entry. 

 

Left-click>OK on the Delete Object form that appears to remove the database – note that there is no undo / 

confirmation for this action. 

Close the Microsoft SQL Server Management Studio for now. 
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Migrating the database 

Start the Microsoft SQL Server Migration Assistant for Access, Close the wizard if it starts since this doesn’t allow 

the required settings to be changed. 

From the main menu, File>New Project, give the migration project a name and location to store the settings, and 

set the version of SQL Server for the target SQL Server, then left-click>OK. (Overwrite the project if a migration 

project of the same name already exists) 

Use the Add Databases toolbar button to add the source Access database file. Expand the tree view to see the 

database name and enable the tables of interest. 

(In this example, the provided OrCAD Capture sample Bench database is being migrated and all of the tables are 

relevant) 

 

Left-click the database name entry in the tree view, BENCH in this case, and, on the upper right, the database 

details will be shown. Left-click on the Type Mapping tab to view the mapping between Access and SQL Server 

datatypes. Double-click on the Text [*..*] Source Type and change the mapping to Varchar (length), also unset the 

Length / Replace with option of 1. 
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Left-click>OK to close the Edit Type Mapping form. 

Left-click the Apply button for “There is unsaved data on this page” message to save the change. 

Then left-click on the Connect to SQL Server button on the toolbar and check that the required SQL Server is the 

target and specify a name for the migrated database, Bench in this case. 

 

Left-click>Connect 

 

Left-click>Yes to create the database 

Once the SQL Server is connected with the database created, left-click the Convert Load and Migrate toolbar 

button. 

Left-click>OK on the Synchronize with Database form to accept the conversion phase. 

The data will be migrated with to the SQL Server target database. Use the Reports buttons and the Output 

window to view the migration actions and messages. Note that some Table and Field Names that are supported in 

Microsoft Access are not permitted in SQL Server so check the reports for any changes that have been made. 

Left-click>Close on the Convert, Load and Migrate form 

Use File>Exit to leave the Microsoft SQL Server Migration Assistant for Access, save the Migration Project and 

Metadata, if required. 
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Configure a User Account for the SQL Server database 

Windows Authentication can be used to access the database but, whilst secure, this isn’t especially convenient 

since each User Account wanting to use the database will need to be added to the allowed logins and database 

security list. Using an SQL Server Authentication account allows the User Name and Password to be set for the 

login and configured when the ODBC datasource is set up for CIS for each machine. (See Appendix if SQL Server 

Authentication isn’t enabled, which would be the case if SQL Server wasn’t installed with the “Mixed Mode” 

option) 

Start the Microsoft SQL Server Management Studio and locate the target database, open the Security collection 

and right-click>New Login on the Logins entry. 

 

Specify a Login Name for the User account, check the SQL Server Authentication option, set and confirm the 

Password, uncheck the Enforce Password Policy option since options like password expiry wouldn’t be too useful 

in this case. 
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Under Select a Page, left-click>User Mapping 

 

Enable the option for the migrated database and set the Database Role Membership. 

(Typical Role Membership settings shown, you will need to check that these meet your requirements) 

Left-click>OK to add the new Login with these options. 

Close the Microsoft SQL Server Management Studio. 
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Configuring the ODBC Datasource 

Go to Start Menu, Windows System, Control Panel, select an Icon View, navigate to Administrative Tools and then 

ODBC Data Sources (64-bit). 

Select the System DSN tab and use the Add button to add a new Data Source. Select the SQL Server driver entry 

with a left-click and left-click Finish. 

In the Create a New Data Source to SQL Server form, give the Data Source a Name, a Description (if required) and 

Specify the Server Name that the target database is running on. 

 

Left-click>Next 

Select “With SQL Server Authentication” and enter the User Name and Password for the Login that was created in 

Microsoft SQL Server Management Studio, if that is being used. 
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Left-click>Next, enabled when the Login ID and Password are entered, this will cause the database to be 

contacted. 

Set the box for “Change the default database” and pick the required database from the list, Bench in this case. 

Leave the other default settings and left-click>Next 

 

Left-click>Finish 

Left-click>Test Data Source to confirm the connection settings. 

Left-click>OK twice to close the forms related to the connection test and the ODBC setup. 

Left-click>OK to close the ODBC Data Source Administrator (64-bit) form. 

The ODBC Data Source is now configured. 
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Configuring OrCAD Capture CIS to use the ODBC Data Source 

Start OrCAD Capture CIS and open a design. 

Go to Options>CIS Configuration and left-click>New to start the Configuration wizard. 

Left-click>Next to start the Database setup. 

Left-click on the Data Source name configured in the previous section from the list. 

 

Left-click>Next once the ODBC Data Source name has been selected. 

You may be prompted for the password for the SQL user. 

Select the Tables to use from the list. (dbo.<Table Name> for each of the tables except TMPPRTS) 

(Note that the Table and Field Names will probably differ in your database) 
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Left-click>Next 

Select the database fields to be mapped to the OrCAD Capture Part Number and Value properties. 

 

Left-click>Next to use the same properties for each of the remaining Tables to configure in Step 3. 

The Part Type and Schematic Part field names match the expected database field names. 

 

Left-click>Next to use the properties for each of Tables for Step 4 



 
 
Migrating Microsoft Access DB to Microsoft SQL Server  

  
© 2020 Parallel Systems Limited  Page 10 of 12 

 

In Step 5, check the box for the PCB Footprint and accept the default Allegro PCB Footprint value for the database 

field to use and left-click>Next to use the PCB Footprint Property form each of the tables. 

Left-click>Next to accept the defaults for Step 6. (The transferred properties can be edited at any time from the 

CIS Configuration Setup) 

In Step 7, enable any Browsable Properties. (For example, if you have a Datasheet field that might be a candidate 

but, again, the Browsable properties can be edited at any time from the CIS Configuration Setup) 

Left-Click>Next 

In Step 8, left-click>Next 

Accept the defaults in Step 9 with left-click>Finish 

The Configure Database form appears, the settings can be checked for each Table, left-click>OK to close the form, 

then Name and Save the DBC file that stores the database mapping. 

Left-click>OK to close the CIS Mapping form. 

OrCAD Capture CIS is now configured to use the database. 
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Appendix: Getting the required downloads 

The required downloads are sourced from Microsoft resources so providing direct links is unlikely to be reliable. 

Perform a search for “Microsoft SQL Server Express download”. On the search results, the Microsoft SQL Server 

Downloads page has downloads for Microsoft SQL Server Express and for Tools: SQL Server Management Studio 

(SSMS), to manage the SQL Server; and Data Migration Assistant, to migrate the data. 

Appendix: Moving the database from a test migration to a shared Microsoft SQL Server 

It’s quite likely that the migration from Microsoft Access to Microsoft SQL Server would be carried out in a test 

environment and then moved to a “live”, or production, Microsoft SQL Server instance. Using the SQL Server 

Management Studio, the Database can be backed up to a file on the test machine and then restored on the “live” 

machine. 

Refer to this note: https://docs.microsoft.com/en-us/sql/relational-databases/backup-restore/create-a-full-

database-backup-sql-server?view=sql-server-ver15 on creating a full backup of the database.   

Once the backup has been created, copy the “bak” file to the “live” machine and refer to this note: 

https://docs.microsoft.com/en-us/sql/relational-databases/backup-restore/restore-a-database-backup-using-

ssms?view=sql-server-ver15 for a comprehensive description of the process and steps to take 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

https://docs.microsoft.com/en-us/sql/relational-databases/backup-restore/create-a-full-database-backup-sql-server?view=sql-server-ver15
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https://docs.microsoft.com/en-us/sql/relational-databases/backup-restore/restore-a-database-backup-using-ssms?view=sql-server-ver15
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Appendix: Enabling SQL Server Mixed Mode 

If SQL Server Mixed Mode wasn’t selected during the SQL Server installation process, SQL Server Mixed Mode, 

which enables User Name and Password account access, rather than Windows Authentication, can be enabled as 

follows: 

Start the Microsoft SQL Server Management Studio. 

Right-click>Properties on the Server Name entry at the top of the Object Explorer on the left hand side. Select 

Security in the Server Properties form. Enable the Option for SQL Server and Windows Authentication Mode. 

 

Left-click>OK to accept the settings. 

 

 

The following are trademarks or registered trademarks of Cadence Design Systems, Inc. 555 River Oaks Parkway, San Jose, CA 95134  
Allegro®, Cadence®, Cadence logo™, Concept®, NC-Verilog®, OrCAD®, PSpice®, SPECCTRA®, Verilog® 
Other Trademarks  
All other trademarks are the exclusive property of their prospective owners.  

NOTICE OF DISCLAIMER: Parallel Systems is providing this design, code, or information "as is." By providing the design, code, or information as one possible 

implementation of this feature, application, or standard, Parallel Systems makes no representation that this implementation is free from any claims of 
infringement. You are responsible for obtaining any rights you may require for your implementation. Parallel Systems expressly disclaims any warranty 
whatsoever with respect to the adequacy of the implementation, including but not limited to any warranties or representations that this implementation is free 
from claims of infringement and any implied warranties of merchantability or fitness for a particular purpose. 


